06-11-2015

OpenSSL Patches Six Security Vulnerabilities

This morning, OpenSSL released six security patches—versions 1.0.2b, 1.0.1n, 1.0.0s, and 0.9.8zg—for new security vulnerabilities discovered in OpenSSL. These patches fix six vulnerabilities: five are rated moderate risk and one is classified as low risk.

For a full list, see the OpenSSL advisory.

None of these bugs affects SSL Certificates; no action related to certificate management is required.

Administrators should update their instances of OpenSSL:

  • OpenSSL 1.0.2 users should upgrade to 1.0.2b
  • OpenSSL 1.0.1 users should upgrade to 1.0.1n
  • OpenSSL 1.0.0d (and below) users should upgrade to 1.0.0s
  • OpenSSL 0.9.8r (and below) users should upgrade to 0.9.8zg

Source code is available for the OpenSSL patches here.

Keeping OpenSSL Secure

As part of the industry's refocus on strengthening the security in the cores services that multitude organizations rely on, OpenSSL continues to discover and then patch vulnerabilities in the OpenSSL framework. This process of finding and fixing is needed for long-term security and to keep the projects strong and hopefully, to patch these vulnerabilities before attackers can deduce ways to take advantage of them. Although the time and energy required to apply the patches can frustrate even the most dedicated system admin, these steps are needed to keep the OpenSSL code secure now and for years to come.

UP NEXT
file

3 Surprising Uses of PKI in Big Companies and How to Ensure They Are all Secure

Featured Stories

03-01-2021

Why It’s Never Been a Better Time to Automate

01-10-2021

DigiCert shuts down legacy Symantec TLS systems with migration of more than 250,000 customers and partners to CertCentral

11-27-2019

Looking beyond the Lock – Reliable Identity in Today’s Web Age